Fix Broken Plugins with WordPress 2.9

Ever since I upgraded to WordPress 2.9, some of the plugins no longer working.

Some plugins will simply showing an error, You do not have sufficient permissions to access this page, when you accessing the Settings page.
WordPress Error

I tried to contact those plugin developers, however, many no longer update their plugins.

So, I decided to look into the code myself. And here is the small trick to make them working again.

Goto Plugins menu, use the Editor to open the plugin source code. Search for the hook, admin_head.
WordPress

Change the hook name to admin_menu, and click save.
WordPress

Now, your plugins should work again. Note that, this steps may not solves all the broken plugins.

By the way, if you schedule your posts in advance and have some WordPress cron jobs running (like backup, RSS, ping, etc), then might be worth to learn how to fix them. If not, just wait for WordPress 2.9.1, should be out soon.

Posted in WordPress Tagged with: ,

Leave a Reply